Conecta con nosotros

Hola, ¿qué estás buscando?

Actualidad

Ubuntu 22.04.3 LTS y Ubuntu 23.04 llegaron con un problema de seguridad que tienes que corregir

ubuntu

Si instalaste de cero Ubuntu 22.04.3 LTS, Ubuntu 23.04 u otras «instalaciones realizadas desde abril de 2023 que aceptaron la actualización de la versión Snap», hay un problema de seguridad que requiere de tu atención y que tienes corregir. Sí, tú; tienes que corregirlo a mano.

Según informan en Phoronix, «las instalaciones de Ubuntu 23.04 y 22.04.3 no han estado siguiendo sus propias mejores prácticas de seguridad» y aunque el error ya ha sido corregido, quienes instalaron las versiones de Ubuntu mencionadas en el periodo señalado tienen que arreglarlo por su cuenta. Pero ¿en qué consiste el problema y cómo se soluciona?

En qué consiste el problema lo sintetiza el reporte del error: «En una instalación predeterminada de Ubuntu Desktop 23.04, la fuente del repositorios de seguridad es http://pt.archive.ubuntu.com/ubuntu, pero debería ser http://security.ubuntu.com/ubuntu». Es decir, el repositorio oficial para las actualizaciones de seguridad ha sido reemplazado por la réplica que se suele adjudicar en la instalación dependiendo del país del usuario.

Lo anterior significa que los usuarios afectados han estado recibiendo las actualizaciones de seguridad del sistema desde réplicas localizadas de los repositorios oficiales, lo cual puede no parecer algo muy grave, porque al fin y al cabo las actualizaciones han llegado de igual modo a los usuarios, pero lo cierto es que, tal y como lo describen en Phoronix, Ubuntu no ha seguido sus propias reglas.

A saber: aunque Ubuntu promueve el uso de réplicas para favorecer una mayor velocidad en la descarga de actualizaciones, así como para aligerar los servidores de Canonical, hay una excepción: las actualizaciones de seguridad. Estas se realizan en todos los casos desde los servidores de Canonical, garantizando así su pronta distribución. No hay más.

¿Qué más da que tarde un poco más en llegar el parche? Algo dará, cuando el reporte de error fue aceptado y marcado como crítico. En todo caso, cabe agregar que los paquetes que hay en los servidores de Ubuntu, oficiales o réplicas, están firmados, por lo que salvo alguna cosa rara que siempre puede suceder, no hay riesgo de colar por ahí nada.

Para que se entienda mejor: si alguno de los servidores réplica reemplazase los paquetes compilados por Canonical por otros, el sistema no los aceptaría. Nunca se puede hablar en términos absolutos en estos temas, pero esa es la teoría. Pese a ello, por cuestiones de velocidad, pero también de control, las actualizaciones de seguridad de Ubuntu vienen siempre de los servidores centrales gestionados por Canonical.

Cómo comprobar si estás afectado y cómo solucionarlo

Con la información previa presente, tanto para comprobar si estás afectado como para, de estarlo, ponerle solución, tienes que echar un vistazo a tus repositorios. Puedes hacerlo vía terminal:

sudo nano /etc/apt/sources.list

Advertencia, desplázate para continuar leyendo

Busca ahora toda línea que incluya «-security» (sin las comillas) y cambia la URL a «http://security.ubuntu.com/ubuntu«. Por ejemplo (así lo tenía yo en Ubuntu 23.04):

deb http://es.archive.ubuntu.com/ubuntu lunar-security main restricted
# deb-src http://es.archive.ubuntu.com/ubuntu lunar-security main restricted
deb http://es.archive.ubuntu.com/ubuntu lunar-security universe
# deb-src http://es.archive.ubuntu.com/ubuntu lunar-security universe
deb http://es.archive.ubuntu.com/ubuntu lunar-security multiverse
# deb-src http://es.archive.ubuntu.com/ubuntu lunar-security multiverse

Esos son los repositorios para las actualizaciones de seguridad, me aparecían abajo del todo y, como se puede ver, muestran el problema de marras. tendrían que verse así (las líneas comentadas con almohadilla no tienen efecto):

deb http://security.ubuntu.com/ubuntu lunar-security main restricted
# deb-src http://security.ubuntu.com/ubuntu lunar-security main restricted
deb http://security.ubuntu.com/ubuntu lunar-security universe
# deb-src http://security.ubuntu.com/ubuntu lunar-security universe
deb http://security.ubuntu.com/ubuntu lunar-security multiverse
# deb-src http://security.ubuntu.com/ubuntu lunar-security multiverse

Una vez editado se guardan los cambios y está hecho. Si acaso, puedes aprovechar para actualizar.

¿Es para tanto el problema? Depende de cómo se mire. hay quien apunta a que peor que el error es el tiempo que se ha tardado en darse cuenta del mismo.

Click para comentar
Advertencia
Advertencia

Te recomendamos

Actualidad

Si hace un rato recogíamos el lanzamiento de la nueva versión de Qubes OS, el «sistema operativo razonablemente seguro», hacemos ahora lo propio con Tails, el amnesic...

Actualidad

Qubes OS 4.2.2 es la nueva versión de la distribución basada en Fedora y fuertemente centrada en la seguridad a través del concepto de...

Actualidad

La encuesta de Steam correspondiente al mes de junio de 2024 ha arrojado algunos datos curiosos en torno a Linux, un sistema cuya trayectoria...

Actualidad

Kaspersky ha publicado su informe ‘Exploits and vulnerabilities in Q1 2024’ y el resumen sería que todo va a más, especialmente para el ámbito...